Stay22 is currently being impacted as a result of the Cloudflare outage

Incident Report for Stay22

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:14 UTC

Identified

We are currently experiencing disruption to our services due to a widespread outage from Cloudflare.
Posted Dec 05, 2025 - 08:49 UTC
This incident affected: Products (Map, Allez, Hub, Spark).